Benutzer-Werkzeuge

Webseiten-Werkzeuge

doku:couchdb_compile

CouchDB: compile yourself

Debian

Debian 5 comes with CouchDB 0.8 - this is too old. The same is true for Ubuntu 9.04 and 9.10.

I will show how to compile CouchDB 1.0.

install and remove old packages:

  • apt-get install couchdb
  • apt-get remove erlang erlang-nox couchdb

Why? It's a good idea to install the debian Packages to resolve all dependencies. But you should remove this 3 packages before install the self-compiled versions.

Compile erlang

⇒ erlang installed in /usr/local

Test: start erl (Quit with Ctrl-C, Ctrl-C, ….)

Compile CouchDB

  • - apt-get install cdbs debhelper erlang-dev help2man libicu-dev libmozjs-dev
  • apt-get install libcurl4-openssl-dev (configure: error: Library requirements (curl) not met)
  • ./configure && make
    • if you get the error message: configure: error: The installed Erlang version is less than 5.6.5 (R12B05). than you have to compile a newer version of erlang. See above.
  • make install

Test: http://localhost:5984/_utils/index.html

Permalink doku/couchdb_compile.txt · Zuletzt geändert: 28.07.2010 14:56 von kfr

oeffentlich